This plugin is vulnerable flash linux fail

How To Update Flash on Firefox & Iceweasel Debian or Ubuntu

“This plugin is vulnerable and needs to be updated”

Yes, flash is notoriously vulnerable and is updated almost weekly because it’s in almost everyone’s browser and is an easy target for hackers.

To update flash on Debian, open a terminal and execute:

1
sudo /usr/sbin/update-flashplugin-nonfree --install

This will download the latest flash plugin for firefox/iceweasel and install it into your browser:

Before:

Update flash on firefox or iceweasel Debian before.

After:

Update flash on firefox or iceweasel Debian after.